Comment installer easieR

Afin d’installer easieR correctement, la première chose à réaliser est de télécharger R. Voici le lien de téléchargement pour les utilisateurs windows et celui pour les utilisateurs mac . Attention, les utilisateurs mac devront aussi installer Xquartz .

Une fois R téléchargé, vous devez l’installer. Pour cela, double-cliquez sur l’icône et cliquez sur suivant jusqu’à ce le logiciel soit installé.

Une fois que vous avez réalisé ces opérations, l’étape suivante consiste à ouvrir R. La fenêtre qui apparaît s’appelle la console. Dans la console, il faut taper (et appuyer ensuite sur entrée) :

install.packages("devtools")

Une boîte de dialogue vous demande de choisir le CRAN. Par défaut, il propose les serveurs sécurisés, qui peuvent poser quelques soucis en fonction des paramètres de votre ordinateur. Dès lors, allez tout en bas de la liste et choisissez « http mirrors » (ou « other mirrors »), une nouvelle liste apparaît. Fondamentalement, vous pouvez choisir n’importe quel site CRAN. Il est d’usage d’utiliser un CRAN relativement proche de vous (Lyon, Paris pour les utilisateurs français par exemple).

Normalement, le package « devtools » est à présent installé. Il faut le charger. Pour charger un package, on utilise la fonction library. Une fois que le package est chargé, vous pouvez l’utiliser pendant toute la durée de la session sans devoir le charger à nouveau. Donc, pour charger le package « devtools », il faut taper dans la console (et appuyer ensuite sur entrée) :

library(devtools)

Si un message d’erreur survient ici (« erreur » apparaît dans la console), c’est que vous n’avez pas réalisé correctement les opérations qui précèdent. Si le package est installé correctement, R va indiquer :

##Le chargement a nécessité le package : devtools

Il se peut aussi que rien ne soit affiché. Ce n’est pas grave.
Vous pouvez installer easieR à présent grâce à la ligne de commande :

install_github("NicolasStefaniak/easieR")

Vous savez que easieR est installé en tapant :

library(easieR)

R doit afficher le message suivant :

##############
 Welcome in easieR -  For more information, please visit :https://theeasierproject.wordpress.com/
 If you are using easieR for the first time, please use the function ez.install in order to ensure that easieR will work properly.
 Si vous utilisez easieR pour la 1e fois, veuillez utiliser la fonction ez.install pour vous assurer de bon fonctionnement de easieR.
Les accents / caracteres speciaux ont volontairement ete supprimes pour assurer la portabilite de easieR sur tous les ordinateurs.
Pour citer easieR dans vos publication / to cite easieR in you publications use :
  Stefaniak, N. (2018). easieR: An R metapackage. Retrieved from https://github.com/NicolasStefaniak/easieR
##############

Pour pouvoir profiter de l’ensemble des fonctionnalités de easieR, il est nécessaire d’installer deux choses : le package « WRS » et pandoc.

Pour installer le package « WRS », il suffit de taper :

install_github("nicebread/WRS")

Pour pandoc, la procédure est un peu différente pour les utilisateurs windows et mac. Pour les utilisateurs windows, il suffit de taper (et charger easieR avant si ce n’est pas fait) :

library(easieR)
easieR()

Dans ce cas, easieR vous proposera d’installer pandoc.

Pour les utilisateurs mac, il faut se rendre sur le site de pandoc et de l’installer manuellement.

Pour vous assurer que l’installation s’est déroulée correctement, easieR a une fonction qui teste l’installation. Il vous est recommandé de l’utiliser lors de la première utilisation de easieR en tapant :

ez.install()

Chaque fois que vous fermez R, les packages sont déchargés. Pour pouvoir utiliser easieR, il faudra donc utiliser la fonction library et ensuite, vous pourrez utiliser la fonction easieR :

library(easieR)
easieR()
Publicités

Une réflexion sur « Comment installer easieR »

Les commentaires sont fermés.